Adding New Media Files to Content Library Issues

Incident Report for Hootsuite Inc.

Resolved

Issues with Content Library media upload are now resolved. Thanks for your patience while our team worked to resolve this.
Posted Feb 10, 2025 - 15:15 PST

Investigating

Hey there. We are experiencing issues with the Content Library. You may have trouble with adding new media files to your Content Library. Our team is working to fix this as quickly as possible. Thank you in advance for your understanding.

Please subscribe to receive status updates.
Posted Feb 10, 2025 - 13:45 PST
This incident affected: Hootsuite Web Application.