Issues accessing Hootsuite dashboard
Incident Report for Hootsuite Inc.
Resolved
We are able to confirm that the issues with accessing the Hootsuite Dashboard have been resolved as of December 5th, 4:38pm PST. Thank you for your patience.
Posted Dec 05, 2024 - 16:50 PST
Investigating
Hello,

We are experiencing an issue with the Hootsuite dashboard. You may encounter difficulties in accessing your Hootsuite account. Our team is working to fix this as quickly as possible.

Thank you in advance for your understanding.
Posted Dec 05, 2024 - 16:16 PST
This incident affected: Hootsuite Web Application.