Delays in Talkwalker Reports and Alerts delivery

Incident Report for Hootsuite Inc.

Resolved

We are able to confirm that the issues with report and alert delivery have been resolved. Thank you for your patience.
Posted Jul 29, 2025 - 10:42 PDT

Monitoring

We have deployed a fix and can confirm that the issues with report and alert delivery have been resolved. Deliveries are now returning to normal processing times.

Our team will continue to monitor the system to ensure continued stability. Thank you for your patience.
Posted Jul 29, 2025 - 07:54 PDT

Identified

We are currently investigating an issue causing delays in the delivery of reports and alerts for Talkwalker. Our engineering team is actively working to identify the root cause and restore normal service as quickly as possible. We apologize for any disruption this is causing and thank you for your patience.
Posted Jul 29, 2025 - 07:11 PDT
This incident affected: Talkwalker Web Application.