Billing Page Issues

Incident Report for Hootsuite Inc.

Resolved

Our billing system provider has recovered from the outage and billing services are now running and fully accessible in Hootsuite. Thanks for your patience while our team worked to resolve this.
Posted Feb 15, 2025 - 03:10 PST

Monitoring

Hey there,

We are currently experiencing an outage with our billing system provider, which is impacting billing-related actions. Some Professional and Team plan customers may encounter a ‘500’ error on the billing pages and be unable to make plan changes or similar updates.

Our team is actively monitoring the incident. Thank you for your patience and understanding.

Please subscribe to receive status updates.
Posted Feb 15, 2025 - 02:06 PST
This incident affected: Hootsuite Web Application.