Hootsuite login difficulties

Incident Report for Hootsuite Inc.

Resolved

We are able to confirm that the issues with logging into your Hootsuite account have been resolved. Thank you for your patience. If you encounter any further issues, please contact our Customer Support team.
Posted May 29, 2026 - 12:05 PDT

Identified

Hey there. We are experiencing issues with logging into Hootsuite. You may have trouble accessing your Hootsuite dashboard. Our team is working to fix this as quickly as possible. Thank you in advance for your understanding.
Posted May 29, 2026 - 11:23 PDT
This incident affected: Hootsuite Web Application and Hootsuite Mobile Application.