We're pleased to inform you that the X issue affecting our services has been resolved as of 18th of November at approximately 6:40am PST.
Our engineering team has verified the fix, and services have been restored to normal operation.
Thank you for your patience and cooperation throughout this incident.
Posted Nov 18, 2025 - 07:26 PST
Monitoring
We are pleased to report that the API success rates for X/Twitter have returned to normal levels. We are beginning to see key services recover functionality.
Our teams will continue to actively monitor the platform to ensure complete stability across all Hootsuite services.
Posted Nov 18, 2025 - 06:47 PST
Identified
Hello,
We’ve identified that due to a global Cloudflare incident, X/Twitter is experiencing intermittent API issues, affecting multiple Hootsuite services including Publishing, Connecting/Reconnecting X/Twitter profiles, Analytics, Listening, Talkwalker and Inbox functionality.
These issues have started at approximately 05:00am PST. Our team is actively investigating to determine the impact, and we will provide updates as soon as we have more information.
Thank you for your kind patience and understanding.
Posted Nov 18, 2025 - 05:57 PST
This incident affected: Hootsuite Web Application, Hootsuite Mobile Application, Sparkcentral Web Application, and Talkwalker Web Application.