Issues publishing videos to Facebook Pages

Incident Report for Hootsuite Inc.

Resolved

We can confirm that the issues when publishing video content to Facebook have been resolved and are now functioning as normal. Any posts that may have failed during this time can now be rescheduled.

We appreciate your patience and understanding.
Posted Mar 12, 2026 - 20:48 PDT

Update

We are seeing a reduction in errors regarding video publishing for Facebook. We continue to monitor the situation.

We sincerely apologize for the disruption to your workflow.
Posted Mar 12, 2026 - 19:41 PDT

Monitoring

We have identified the cause of the video publishing issues. This disruption is due to a technical issue on Meta’s side affecting video processing across their platform.

Because the root cause lies within Meta’s infrastructure, our team is currently monitoring their progress toward a resolution. We will provide another update as soon as we receive confirmation from Meta that their services are recovering.

Thank you for your continued patience.
Posted Mar 12, 2026 - 09:06 PDT

Identified

We are currently investigating issues impacting the ability to publish videos to Facebook.
Users may experience errors or failed uploads when attempting to post video content to Facebook pages. Our engineering team is actively investigating the issue to identify the root cause and path to resolution as soon as possible
We sincerely apologize for the disruption to your workflow.
Posted Mar 12, 2026 - 08:29 PDT
This incident affected: Hootsuite Web Application and Hootsuite Mobile Application.