Publishing & Approvals Issues

Incident Report for Hootsuite Inc.

Resolved

We can confirm that the intermittent issues affecting publishing, approvals, and the inbox have been resolved. We appreciate your patience while our team sorted this out.
Posted Mar 18, 2025 - 10:17 PDT

Monitoring

Hey there! We're currently experiencing intermittent issues affecting publishing, approvals, and the inbox. Our team is actively working to resolve this as quickly as possible. We appreciate your patience and understanding.

Please subscribe to receive status updates.
Posted Mar 18, 2025 - 08:53 PDT
This incident affected: Hootsuite Web Application and Hootsuite Mobile Application.