Dashboard Navigation Issues

Incident Report for Hootsuite Inc.

Resolved

We are able to confirm that the issues affecting the Global Navigation Menu have now been resolved. Users can now successfully navigate to different areas of the platform through the navigation menu. If you continue to experience issues, please reach out to our support team.
Posted Jul 27, 2026 - 14:09 PDT

Investigating

Hey there. We are experiencing issues with the Global Navigation Menu. You may have trouble navigating to different areas of the platform. Our team is working to fix this as quickly as possible. Thank you in advance for your understanding.

Please subscribe to receive status updates.
Posted Jul 27, 2026 - 13:44 PDT
This incident affected: Hootsuite Web Application.