Hootsuite Dashboard login difficulties using X sign in method

Incident Report for Hootsuite Inc.

Resolved

We have resolved the issues with the X sign in method when logging into your Hootsuite dashboard. If you continue to have issues logging into Hootsuite using the X sign in method, please reach out to our customer support team.
Posted Jul 28, 2026 - 12:02 PDT

Identified

We have found the root of the issue impacting the X sign in method when logging into Hootsuite and are working on resolving it. While we do so you may still have trouble using X as a sign in method to login to your Hootsuite dashboard. Thank you for your continued patience.
Posted Jul 28, 2026 - 11:21 PDT

Investigating

We are experiencing issues with the X sign in method when logging into your Hootsuite dashboard. You may have trouble using X as a sign in method to login to your Hootsuite dashboard. Our team is working to fix this as quickly as possible. Thank you in advance for your understanding.
Posted Jul 28, 2026 - 10:52 PDT
This incident affected: Hootsuite Web Application and Hootsuite Mobile Application.