We have noticed a decrease in errors with X/Twitter streams in Hootsuite dashboards. You may continue to experience difficulty in loading content intermittently. Our engineering team continues to investigate the issue and will implement a fix as needed. Please contact our Hootsuite support team if you require further assistance.
Posted Mar 26, 2025 - 15:15 PDT
Monitoring
We have noticed a decrease in errors with X/Twitter streams in Hootsuite dashboards. You may continue to experience difficulty in loading content intermittently. Our engineering team continues to investigate the issue and will implement a fix as needed. Please contact our Hootsuite support team if you require further assistance.
Posted Mar 26, 2025 - 15:15 PDT
Investigating
Hey there. We are experiencing intermittent issues with the Home and My Tweets streams in Hootsuite for X social networks. You may have trouble with reviewing content in these streams. Our team is working to resolve the issue as quickly as possible. We thank you in advance for your understanding.
Please subscribe to receive status updates.
Posted Mar 26, 2025 - 13:10 PDT
This incident affected: Hootsuite Web Application.