We are able to confirm that the difficulties with logging into Hootsuite have been resolved. If you encounter any further issues with logging into Hootsuite, please reach out to our customer support team. Thank you for your patience.
Posted Jul 27, 2026 - 19:46 PDT
Monitoring
Our team identified the root cause and released an update to address the behavior — you should no longer experience trouble logging in with your email and password or see an error stating your organization is not set up for SSO. If you continue to experience any difficulties, please reach out to our support team. Thank you for your patience.
Posted Jul 27, 2026 - 18:59 PDT
Investigating
Hey there. We are experiencing issues with logging into the Hootsuite platform. You may have trouble logging in with your email and password, or may see an error stating your organization is not set up for SSO. Our team is working to fix this as quickly as possible. Thank you in advance for your understanding.
Please subscribe to receive status updates.
Posted Jul 27, 2026 - 15:48 PDT
This incident affected: Hootsuite Web Application and Hootsuite Mobile Application.