We can confirm that the issue affecting users' ability to add/reconnect their Youtube accounts to Hootsuite has been resolved and that all YouTube accounts that were disconnected as a result of this issue have been reconnected.
Thank you for your patience and understanding
Posted Jul 18, 2025 - 11:46 PDT
Monitoring
Youtube is currently experiencing difficulties that impact users' ability to add or reconnect their YouTube accounts to Hootsuite, as well affecting Youtube data for Analytics. As a result, you may have issues adding a new Youtube account to Hootsuite, reconnecting an existing Youtube account to Hootsuite or seeing data discrepancies in your YouTube data within Hootsuite Analytics.
Our team is monitoring the situation.
Please subscribe to receive status updates
Posted Jul 18, 2025 - 09:10 PDT
This incident affected: Hootsuite Web Application and Hootsuite Mobile Application.