Delays in retrieving content for Inbox 2.0

Incident Report for Hootsuite Inc.

Resolved

Inbox 2.0 is now back to full functionality. Thanks for your patience while we worked to resolve this.
Posted Oct 22, 2025 - 13:56 PDT

Investigating

Hey there!

We are experiencing issues with inbound content populating within Inbox 2.0. Our team is working to fix this as quickly as possible. Thank you in advance for your understanding.

Please subscribe to receive status updates.
Posted Oct 22, 2025 - 12:59 PDT
This incident affected: Hootsuite Web Application and Hootsuite Mobile Application.