Loading issues with the Billing page

Incident Report for Hootsuite Inc.

Resolved

We're pleased to inform you that the issue affecting users' ability to access their Billing page has been successfully resolved. Users are now able to access their Billing page, and perform billing-related actions.

Our engineering team has implemented a fix, and services have been restored to normal operation.

Thank you for your patience and cooperation throughout this incident.
Posted Aug 25, 2025 - 07:18 PDT

Investigating

We are currently experiencing some technical difficulties with our billing system provider, which is impacting billing-related actions. Some of our customers may encounter a ‘500’ error on the billing pages and be unable to make plan changes or similar updates.

Our team is actively monitoring the incident. Thank you for your patience and understanding.
Posted Aug 25, 2025 - 04:58 PDT
This incident affected: Hootsuite Web Application.