X/Twitter API Disruptions

Incident Report for Hootsuite Inc.

Resolved

As of 11:30 AM PST on March 10th, 2025, X has been back up and running and fully accessible via the Hootsuite dashboard.

- Streams: During the period of time that X experienced the issues, streams were not loading; no data loss is expected, and no user action is required post-recovery.

- Publishing: Users should now be able to send live posts to X accounts. Scheduled X posts that failed throughout the brief interruptions experienced on March 10th, 2025 would need to be rescheduled (https://ow.ly/Rwsu50VfthI).

- Connecting/Reconnecting X Profiles: Users should now be able to authenticate their X profiles within Hootsuite
Analytics: No user action is required; data has been backfilled

- Inbox 2.0: The X messages that were not retrieved during the interruptions will not be recovered
Hootsuite Listening & Talkwalker standalone: All available data has been recovered; users should re-attempt authentication if tokens/channels are disconnected

We appreciate your patience as our teams monitored the situation.
Posted Mar 11, 2025 - 03:30 PDT

Monitoring

Hello,

X/Twitter is experiencing intermittent API issues, affecting multiple Hootsuite services including Streams, Publishing, Connecting/Reconnecting X/Twitter profiles, Analytics, Listening and Inbox functionality.

These issues have started at approximately 02:40am PST. Our team is actively investigating to determine the impact, and we will provide updates as soon as we have more information.

Thank you for your patience.
Posted Mar 10, 2025 - 07:39 PDT
This incident affected: Hootsuite Web Application, Hootsuite Mobile Application, Sparkcentral Web Application, and Talkwalker Web Application.