We are able to confirm that the issues with Ow.ly link services have been resolved. Thank you for your patience.
Posted Sep 20, 2024 - 11:48 PDT
Identified
We are aware of an issue where Ow.ly link services are experiencing difficulties in Composer and existing links may fail to redirect. Our team is actively investigating to identify the root cause and path to resolution as soon as possible.
Posted Sep 20, 2024 - 11:20 PDT
This incident affected: Web Application and Mobile Application.