Issues with uploading and publishing videos from Hootsuite

Incident Report for Hootsuite Inc.

Resolved

We are able to confirm that the issues with uploading and publishing videos from Hootsuite have been resolved. Thank you for your patience.
Posted Jul 28, 2025 - 11:34 PDT

Investigating

We are experiencing issues with uploading and publishing videos from Hootsuite. You may have trouble publishing scheduled/post now content with video or uploading videos to Composer. Our team is working to fix this as quickly as possible. Thank you in advance for your understanding.
Posted Jul 28, 2025 - 09:52 PDT
This incident affected: Hootsuite Web Application.