Unable to login into Hootsuite - "Sign in" button is unresponsive
Incident Report for Hootsuite Inc.
Resolved
We're pleased to inform you that the issue affecting the Hootsuite login page has been successfully resolved. We conducted comprehensive testing on our end and can confidently confirm that everything is now functioning as expected.

Your patience and understanding while our team investigated and resolved the matter are highly appreciated.
Posted Nov 27, 2024 - 06:12 PST
Identified
The issue has been identified, and a fix is being implemented. We appreciate your kind patience and understanding while our team is working towards a resolution.
Posted Nov 27, 2024 - 05:20 PST
Investigating
Hello,

We are experiencing intermittent issues with the Hootsuite login page. You may encounter difficulties in accessing your Hootsuite account, where the email address could appear invalid, and the "Sign in" button is unresponsive. Our team is working to fix this as quickly as possible.

In the meantime, as a potential temporary workaround, users may be able to bypass this situation by entering the "Enter" key, after filling in their login credentials, instead of clicking on the "Sign in" button.

Thank you in advance for your understanding.
Posted Nov 27, 2024 - 02:51 PST
This incident affected: Hootsuite Web Application.