Hootsuite Analytics loading issues

Incident Report for Hootsuite Inc.

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 13:53 PST

Update

We can confirm that the issues affecting Hootsuite Analytics have been resolved and returned to full functionality within the Hootsuite Dashboard.

Thank you for your patience while our team sorted this out.
Posted Feb 26, 2026 - 13:53 PST

Monitoring

Our Engineering team have implemented a fix and we are seeing a reduction in errors related to loading Hootsuite Analytics within the dashboard. In the meantime our teams continue to monitor the situation closely. Thank you for your patience.
Posted Feb 26, 2026 - 11:23 PST

Identified

Hey there. We are experiencing issues with Hootsuite Analytics. You may have trouble successfully loading Hootsuite Analytics at this time. Our team is working to fix this as quickly as possible. Thank you in advance for your understanding.
Posted Feb 26, 2026 - 09:19 PST
This incident affected: Hootsuite Web Application.