Meta Incident Affecting Facebook & Instagram Data Delivery

Incident Report for Hootsuite Inc.

Resolved

We can confirm that the issues affecting Facebook and Instagram message and data delivery in Hootsuite have been resolved. If you continue to experience missing messages in Inbox or incomplete data in Analytics, please reach out to our customer support team.
Posted Jul 19, 2026 - 02:50 PDT

Monitoring

Meta is currently experiencing difficulties that impact Facebook and Instagram messaging and data delivery in Hootsuite. As a result, you may have issues receiving messages in Inbox or seeing complete data in Analytics for these networks.
Please subscribe to our status page to receive status updates.
Posted Jul 19, 2026 - 02:19 PDT
This incident affected: Hootsuite Web Application, Hootsuite Mobile Application, and Sparkcentral Web Application.