Twitter/X Streams Performance Issues

Incident Report for Hootsuite Inc.

Resolved

X/Twitter is back up and fully accessible via the Hootsuite dashboard. Thank you for your patience while we resolved this.
Posted Jul 05, 2026 - 09:04 PDT

Identified

X/Twitter is currently experiencing difficulties that are impacting Twitter/X Nest (Streams and Inbox) Performance in Hootsuite. Our team is working with X/Twitter to resolve this as quickly as possible.
Thank you for your patience.
Posted Jul 05, 2026 - 07:33 PDT
This incident affected: Hootsuite Web Application and Hootsuite Mobile Application.