Hootsuite Dashboard Inaccessible

Incident Report for Hootsuite Inc.

Resolved

All services are back up and running and fully accessible via the Hootsuite dashboard. Thanks for your patience while our team worked to resolve this.
Posted Oct 14, 2025 - 07:28 PDT

Identified

We are currently experiencing a major service disruption that is preventing users from accessing the Hootsuite platform. You may be unable to log in or see an error message when trying to load the dashboard.

The issue began at approximately 7:10 AM PST. Our engineering and operations teams are actively investigating this as their highest priority.

We understand how critical our services are to you, and we sincerely apologize for the impact this is having on your work. We will provide another update as soon as we have more information.
Posted Oct 14, 2025 - 07:16 PDT
This incident affected: Hootsuite Web Application and Hootsuite Mobile Application.