Connecting/reconnecting X accounts in Hootsuite

Incident Report for Hootsuite Inc.

Resolved

The service disruption with X that affected connecting and reconnecting X accounts in Hootsuite, as well as logging in via Social Sign-In, has been resolved. If you continue to experience any issues, please contact our Customer Support team.
Posted May 24, 2025 - 08:57 PDT

Update

While we’re seeing a decrease in errors, the authentication issue related to the X service disruption is still occurring intermittently, impacting the ability to connect or reconnect X accounts within Hootsuite. Our team is actively monitoring the situation. Please note that using “Social Sign In” to log in to Hootsuite with an X account may still be affected at this time as well. We appreciate your continued patience.
Posted May 23, 2025 - 12:09 PDT

Update

While we continue to actively monitor the situation with the X service disruption, kindly note this situation is impacting services in Hootsuite like, connecting/reconnect X accounts, and using X via Social Sign In to login to Hootsuite. We’ll continue to provide updates as new information is made available. For further details on the X service disruption, please visit: https://docs.x.com/status#
Posted May 23, 2025 - 10:41 PDT

Monitoring

We continue to monitor progress from X and are in close contact as their team works toward a resolution. We’ll provide further updates as soon as new information becomes available. For further details, please visit: https://docs.x.com/status#
Posted May 23, 2025 - 05:25 PDT

Investigating

X is currently experiencing difficulties that is impacting connecting/reconnecting X accounts in Hootsuite. As a result, you may encounter difficulties with connecting and reconnecting X accounts in Hootsuite. Our team is actively monitoring the situation. We thank you for your patience.

Please subscribe to receive status updates.
Posted May 22, 2025 - 15:29 PDT
This incident affected: Hootsuite Web Application and Hootsuite Mobile Application.