Publishing issues (X profiles, Facebook pages, Instagram business profiles)

Incident Report for Hootsuite Inc.

Resolved

We are able to confirm that the issues impacting publishing to X profiles, Facebook pages and Instagram Business profiles from Hootsuite have been resolved. Thank you for your patience. Please contact our customer support team if you experience any difficulties with publishing content from Hootsuite.
Posted Feb 17, 2026 - 14:22 PST

Monitoring

We are seeing a reduction in errors related to the publishing issues impacting X profiles, Facebook pages and Instagram business profiles in Hootsuite. In the meantime our teams continue to monitor the situation closely. Thank you for your patience.
Posted Feb 17, 2026 - 12:55 PST

Identified

Hey there. We are experiencing issues with publishing/scheduling to X profiles, Facebook pages and Instagram business profiles from Hootsuite. You may experience content fail to publish when attempting to send posts to X profiles, Facebook Pages or Instagram, including scheduled posts and Post Now posts. Our team is working to fix this as quickly as possible. Thank you in advance for your understanding
Posted Feb 17, 2026 - 12:41 PST
This incident affected: Hootsuite Web Application and Hootsuite Mobile Application.