Issues with Paid Plan sign-up
Incident Report for Hootsuite Inc.
Resolved
This incident has been resolved.
Posted Jan 29, 2025 - 07:42 PST
Identified
We have found the root of the issue with our paid plan sign-up and are working on resolving it. Thank you for your continued patience.

Please subscribe to our status page to receive status updates.
Posted Jan 28, 2025 - 13:31 PST
Investigating
We are currently experiencing issues with our paid plan sign-up. You may have trouble with the unlimited social accounts add-on, where a duplicate instance is added to your account. Our team is working to fix this as quickly as possible. Thank you in advance for your understanding.
Posted Jan 28, 2025 - 09:04 PST
This incident affected: Hootsuite Web Application.