X/Twitter Authentication Issues
Incident Report for Hootsuite Inc.
Resolved
We'd like to inform you that the issue affecting the ability to authenticate your X account within Hootsuite, which was caused by changes on X's (formerly Twitter) side, has now been fully resolved, therefore the integration is once again operating as expected.

To provide more context, the disruption occurred due to X implementing significant changes to their API platform's infrastructure. These changes, which are unprecedented in the industry, are part of a larger shift aimed at enhancing their platform's capabilities in the long term. Unfortunately, the scope and scale of this update caused temporary interruptions to our service that were beyond our control.

Our team will continue to monitor the situation closely to ensure ongoing stability, and we remain committed to delivering a seamless experience for you.

If you experience any lingering issues or have any questions, please don't hesitate to reach out to our support team through the channels available to you.

We understand the inconvenience this may have caused, and we appreciate your patience and understanding while the team at X worked through this.
Posted Oct 04, 2024 - 05:43 PDT
Update
As our partners at X work on a long-term solution to this authentication issue, they have recommended that anyone experiencing these problems try deleting old cookies associated with twitter.com. (Example: If you're using Google Chrome, you can do this by visiting the following link: chrome://settings/content/all?searchSubpage=twitter.com&search=cookie )

Additionally, some users have found that temporarily disabling two-factor authentication (2FA) natively allows them to successfully connect or reconnect their X accounts within Hootsuite.

We appreciate your patience and understanding as we work through this issue with X. Rest assured that it remains a priority for both teams, and we will update you promptly as soon as we have more information or a resolution.
Posted Aug 21, 2024 - 07:50 PDT
Update
We are continuing to monitor for any further issues.
Posted Aug 12, 2024 - 22:52 PDT
Update
We are continuing to monitor for any further issues.
Posted Aug 08, 2024 - 15:38 PDT
Update
Hello,

We’d like to follow up and provide an update regarding the ongoing intermittent authentication issues with X accounts on Hootsuite.

This issue has been confirmed as originating from X’s side. X has also acknowledged the problem on their developer community forum, where they have stated that they are investigating the issue. (X's developer community forum here, https://devcommunity.x.com/t/investigating-issues-with-login-with-x-functionality/221510)

Rest assured we are actively collaborating with X to resolve this issue as swiftly as possible.
We will provide updates here as soon as we have more information.

Thank you for ongoing cooperation and understanding in the matter.
Posted Aug 02, 2024 - 14:24 PDT
Update
Hello,

We'd like to provide an update regarding the ongoing intermittent authentication issues with X/Twitter accounts on Hootsuite.

Our team remains in active collaboration with X/Twitter to resolve this matter promptly. Although there are no new developments to report at this moment, we are closely monitoring the situation and will keep you informed of any progress.

Thank you for your continued understanding and patience.
Posted Jul 01, 2024 - 01:08 PDT
Update
Hey there,

We wanted to provide a quick follow-up on the intermittent issues with authenticating or reauthenticating X/Twitter accounts to Hootsuite.

Our team is still actively working with X/Twitter to resolve the issue as quickly as possible. At this time, there are no new updates to share, however, we are closely monitoring the situation and will keep you informed of any progress.

We appreciate your continued understanding and patience during this time.
Posted Jun 28, 2024 - 05:46 PDT
Monitoring
Hey there,

We are currently experiencing intermittent issues with authenticating or reauthenticating X/Twitter accounts to Hootsuite.

As a result, you may encounter errors when attempting to add or reconnect X/Twitter accounts to Hootsuite. Users might be redirected to the X/Twitter home page instead of the Hootsuite app.

Our team is working with X/Twitter to resolve the issue as quickly as possible. We appreciate your understanding and patience during this time.
Posted Jun 27, 2024 - 05:43 PDT
This incident affected: Web Application and Mobile Application.