All services are back up and running and fully accessible via the Hootsuite dashboard. Thanks for your patience while our team worked to resolve this.
Posted Sep 16, 2025 - 17:35 PDT
Monitoring
We are seeing a reduction in errors related to the Hootsuite Dashboard. Our team continues to work to address this issue. In the meantime you may still have issues performing actions within the dashboard. We are continuing to monitor the situation as services return to full functionality, Thank you for your patience.
Please subscribe to our status page to receive status updates.
Posted Sep 16, 2025 - 17:09 PDT
Update
We are continuing to investigate this issue.
Posted Sep 16, 2025 - 16:38 PDT
Investigating
Hey there. We are experiencing issues with the Hootsuite dashboard, affecting all services. Our team is working to fix this as quickly as possible. Thank you in advance for your understanding.
Please subscribe to receive status updates.
Posted Sep 16, 2025 - 16:30 PDT
This incident affected: Hootsuite Web Application and Hootsuite Mobile Application.