Experiencing login issues with Mozilla Firefox & Safari

Incident Report for Hootsuite Inc.

Resolved

We have resolved the issues related to the login flow when accessing the Hootsuite platform via Safari 26.6 and Mozilla Firefox version 153.01. If you continue to have issues logging into your Hootsuite dashboard via Safari or Mozilla Firefox please reach out to our customer support team. Thank you for your patience.
Posted Jul 30, 2026 - 08:11 PDT

Investigating

We are aware of some issues impacting the login flow when accessing the Hootsuite platform via Safari 26.6 and Mozilla Firefox version 153.01, when upon clicking "Sign In," the page reloads and clears all entered credentials without redirecting to the dashboard or displaying an error message.

While we are currently unable to reproduce the issue, our team is actively investigating and will provide further updates as they become available.

Thank you for your kind patience and understanding.
Posted Jul 30, 2026 - 07:28 PDT
This incident affected: Hootsuite Web Application.